用户注册



邮箱:

密码:

用户登录


邮箱:

密码:
记住登录一个月忘记密码?

发表随想


还能输入:200字
云代码 - 其他代码库

易语言批量替换

2018-10-17 作者:呶呶举报

[其他]代码库

.版本 2
.支持库 iext2

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 局_原始数据, 文本型
.局部变量 局_计次, 整数型
.局部变量 局_被替换的数据, 文本型
.局部变量 局_用作替换数据, 文本型


局_原始数据 = 基础文本.内容
.计次循环首 (2, 局_计次)
    局_被替换的数据 = 多项选择 (局_计次, “Lobby”, “Left Double Door”)
    局_用作替换数据 = 多项选择 (局_计次, “房间大厅”, “左边的双扇门”)
    局_原始数据 = 子文本替换 (局_原始数据, 局_被替换的数据, 局_用作替换数据, , , 假)
.计次循环尾 ()
基础文本.内容 = 局_原始数据


分享到:
更多

网友评论    (发表评论)


发表评论:

评论须知:

  • 1、评论每次加2分,每天上限为30;
  • 2、请文明用语,共同创建干净的技术交流环境;
  • 3、若被发现提交非法信息,评论将会被删除,并且给予扣分处理,严重者给予封号处理;
  • 4、请勿发布广告信息或其他无关评论,否则将会删除评论并扣分,严重者给予封号处理。