用户注册



邮箱:

密码:

用户登录


邮箱:

密码:
记住登录一个月忘记密码?

发表随想


还能输入:200字
云代码 - 其他代码库

易语言超级列表框导入EXCEL表格

2018-10-17 作者:呶呶举报

[其他]代码库

.版本 2
.支持库 iext
.支持库 eExcel2000
.支持库 spec

.子程序 _按钮5_被单击
.局部变量 工作簿对象, 对象
.局部变量 范围, 对象
.局部变量 行列范围, 对象
.局部变量 行对象, 对象
.局部变量 列对像, 对象
.局部变量 单元格对象, 对象
.局部变量 行, 整数型
.局部变量 列, 整数型
.局部变量 n1, 整数型
.局部变量 A列, 文本型
.局部变量 B列, 文本型
.局部变量 C列, 文本型
.局部变量 D列, 文本型
.局部变量 E列, 文本型
.局部变量 F列, 文本型
.局部变量 G列, 文本型
.局部变量 H列, 文本型
.局部变量 I列, 文本型
.局部变量 J列, 文本型
.局部变量 K列, 文本型
.局部变量 L列, 文本型
.局部变量 索引, 整数型

超级列表框1.全部删除 ()
通用对话框1.类型 = 0
通用对话框1.初始目录 = 取运行目录 ()
通用对话框1.过滤器 = “excel文件(*.xlsx)|*.xlsx”
.如果真 (通用对话框1.打开 ())

.如果真结束
编辑框1.内容 = 通用对话框1.文件名
Excel程序1.创建 ()
Excel程序1.显示 = 假
Excel工作簿1.置程序 (Excel程序1)
Excel工作簿1.打开 (通用对话框1.文件名)
Excel工作簿1.激活工作簿 ()
Excel工作簿1.激活表格 ()
Excel工作簿1.表格序号 = 0
工作簿对象 = Excel工作簿1.取表格对象 ()
范围 = 工作簿对象.读对象型属性 (“UsedRange”, )
行对象 = 范围.读对象型属性 (“Rows”, )
行 = 行对象.读数值属性 (“Count”, )
列对像 = 范围.读对象型属性 (“Columns”, )
列 = 列对像.读数值属性 (“Count”, )
调试输出 (行)
调试输出 (列)
.计次循环首 (行, n1)
    Excel工作簿1.首单元格 = “A” + 到文本 (n1)
    Excel工作簿1.尾单元格 = “A” + 到文本 (n1)
    单元格对象 = Excel工作簿1.取单元格对象 ()
    A列 = 单元格对象.读文本属性 (“Value”, )
    Excel工作簿1.首单元格 = “B” + 到文本 (n1)
    Excel工作簿1.尾单元格 = “B” + 到文本 (n1)
    单元格对象 = Excel工作簿1.取单元格对象 ()
    B列 = 单元格对象.读文本属性 (“Value”, )
    Excel工作簿1.首单元格 = “C” + 到文本 (n1)
    Excel工作簿1.尾单元格 = “C” + 到文本 (n1)
    单元格对象 = Excel工作簿1.取单元格对象 ()
    C列 = 单元格对象.读文本属性 (“Value”, )
    Excel工作簿1.首单元格 = “D” + 到文本 (n1)
    Excel工作簿1.尾单元格 = “D” + 到文本 (n1)
    单元格对象 = Excel工作簿1.取单元格对象 ()
    D列 = 单元格对象.读文本属性 (“Value”, )
    Excel工作簿1.首单元格 = “E” + 到文本 (n1)
    Excel工作簿1.尾单元格 = “E” + 到文本 (n1)
    单元格对象 = Excel工作簿1.取单元格对象 ()
    E列 = 单元格对象.读文本属性 (“Value”, )
    Excel工作簿1.首单元格 = “F” + 到文本 (n1)
    Excel工作簿1.尾单元格 = “F” + 到文本 (n1)
    单元格对象 = Excel工作簿1.取单元格对象 ()
    F列 = 单元格对象.读文本属性 (“Value”, )
    Excel工作簿1.首单元格 = “G” + 到文本 (n1)
    Excel工作簿1.尾单元格 = “G” + 到文本 (n1)
    单元格对象 = Excel工作簿1.取单元格对象 ()
    G列 = 单元格对象.读文本属性 (“Value”, )
    Excel工作簿1.首单元格 = “H” + 到文本 (n1)
    Excel工作簿1.尾单元格 = “H” + 到文本 (n1)
    单元格对象 = Excel工作簿1.取单元格对象 ()
    H列 = 单元格对象.读文本属性 (“Value”, )
    Excel工作簿1.首单元格 = “I” + 到文本 (n1)
    Excel工作簿1.尾单元格 = “I” + 到文本 (n1)
    单元格对象 = Excel工作簿1.取单元格对象 ()
    I列 = 单元格对象.读文本属性 (“Value”, )
    Excel工作簿1.首单元格 = “J” + 到文本 (n1)
    Excel工作簿1.尾单元格 = “J” + 到文本 (n1)
    单元格对象 = Excel工作簿1.取单元格对象 ()
    J列 = 单元格对象.读文本属性 (“Value”, )
    Excel工作簿1.首单元格 = “K” + 到文本 (n1)
    Excel工作簿1.尾单元格 = “K” + 到文本 (n1)
    单元格对象 = Excel工作簿1.取单元格对象 ()
    K列 = 单元格对象.读文本属性 (“Value”, )
    Excel工作簿1.首单元格 = “L” + 到文本 (n1)
    Excel工作簿1.尾单元格 = “L” + 到文本 (n1)
    单元格对象 = Excel工作簿1.取单元格对象 ()
    L列 = 单元格对象.读文本属性 (“Value”, )


    索引 = 超级列表框1.插入表项 (, , , , , )
    超级列表框1.置标题 (索引, 0, A列)
    超级列表框1.置标题 (索引, 1, B列)
    超级列表框1.置标题 (索引, 2, C列)
    超级列表框1.置标题 (索引, 3, D列)
    超级列表框1.置标题 (索引, 4, E列)
    超级列表框1.置标题 (索引, 5, F列)
    超级列表框1.置标题 (索引, 6, G列)
    超级列表框1.置标题 (索引, 7, H列)
    超级列表框1.置标题 (索引, 8, I列)
    超级列表框1.置标题 (索引, 9, J列)
    超级列表框1.置标题 (索引, 10, K列)
    超级列表框1.置标题 (索引, 11, L列)
.计次循环尾 ()
Excel工作簿1.关闭 ()
Excel工作簿1.释放 ()
Excel程序1.退出 ()
Excel程序1.释放 ()


分享到:
更多

网友评论    (发表评论)


发表评论:

评论须知:

  • 1、评论每次加2分,每天上限为30;
  • 2、请文明用语,共同创建干净的技术交流环境;
  • 3、若被发现提交非法信息,评论将会被删除,并且给予扣分处理,严重者给予封号处理;
  • 4、请勿发布广告信息或其他无关评论,否则将会删除评论并扣分,严重者给予封号处理。