用户注册



邮箱:

密码:

用户登录


邮箱:

密码:
记住登录一个月忘记密码?

发表随想


还能输入:200字

柯侧耳倾听者    -  云代码空间

—— 翱翔在Java世界的海洋之上

路由器静态路由与RIP动态路由配置

2017-12-15|161阅||

摘要:实验六 路由器静态路由与RIP动态路由配置   一、实验目的与要求 1、掌握静态路由的配置方法和技巧以及通过静态路由方式实现网络的连通性; 2、掌握RIP协议的配置方法以及查看通过动态路由协议RIP学习产生的路由; 3、熟悉广域网线缆的链接方式。

实验六 路由器静态路由与RIP动态路由配置

 

一、实验目的与要求

1、掌握静态路由的配置方法和技巧以及通过静态路由方式实现网络的连通性;

2、掌握RIP协议的配置方法以及查看通过动态路由协议RIP学习产生的路由;

3、熟悉广域网线缆的链接方式。

二、实验原理

1、路由器属于网络层设备,能够根据IP包头的信息,选择一条最佳路径,将数据包转发出去。实现不同网段的主机之间的互相访问。路由器是根据路由表进行选路和转发的。而路由表里就是由一条条路由信息组成。

生成路由表主要有两种方法:手工配置和动态配置,即静态路由协议配置和动态路由协议配置。静态路由是指由网络管理员手工配置的路由信息。静态路由除了具有简单、高效、可靠的优点外,它的另一个好处是网络安全保密性高。缺省路由可以看做是静态路由的一种特殊情况。当数据在查找路由表时,没有找到和目标相匹配的路由表项时,为数据指定路由。

2RIP(Routing Information Protocols,路由信息协议)是应用较早、使用较普遍的IGP 内部网管协议,使用于小型同类网络,是距离矢量协议。

RIP 协议以跳数作为衡量路径开销的多少,RIP协议里规定最大跳数为15。RIP 协议有两个版本:RIP v1 和RIP v2,RIP v1 属于有类路由协议,不支持VLSM,以广播形式进行路由信息的更新,更新周期为30 秒;RIPv2属于无类路由协议,支持VLSM,以组播形式进行路由更新。

三、预习与准备

预习路由器静态路由与RIP动态路由的工作机制及其配置方法的相关知识点。准备好实验设备,安装好模拟器软件Packet Tracer 6.0

四、实验内容与步骤

1、实验背景

1练习一实验背景:学校有新旧两个校区,每个校区是一个独立的局域网,为了使新旧校区能够正常相互通讯,共享资源。每个校区出口利用一台路由器进行连接,两台路由器间学校申请了一条2M的DDN 专线进行相连,要求做适当配置实现两个校区的正常相互访问。

2练习二实验背景:假设校园网通过一台三层交换机连到校园网出口路由器上,路由器再和校园外的另一台路由器连接。现要做适当配置,实现校园网内部主机与校园网外部主机之间的相互通信。为了简化网管的管理维护工作,学校决定采用RIP v2 协议实现互通。

2、实验步骤

1)练习一 路由器静态路由的配置

新建packet tracer拓扑图

 

①、在路由器R1、R2上配置接口的IP地址和R1串口上的时钟频率;

②、查看路由器生成的直连路由;

③、在路由器R1、R2上配置静态路由;

④、验证R1、R2上的静态路由配置;

⑤、将PC1、PC2 主机默认网关分别设置为路由器接口fa 1/0 的IP地址;

⑥、PC1、PC2 主机之间可以相互通信。

 

2)练习二 路由器RIP动态路由的配置

建立建立packet tracer拓扑图

 

①、在本实验中的三层交换机上划分VLAN 10 和VLAN 20,其中VLAN 10 用于连接校园网主机,VLAN 20 用于连接R1。

②、路由器之间通过V.35电缆通过串口连接,DCE端连接在R1 上,配置其时钟频率64000。

③、主机和交换机通过直连线,主机与路由器通过交叉线连接。

④、在S3560 上配置RIP v2 路由协议。

⑤、在路由器R1、R2 上配置RIP v2 路由协议。

⑥、将PC1、PC2 主机默认网关设置为与直连网路设备接口IP地址。

⑦、验证PC1、PC2 主机之间可以互相通信。

 

3、实验设备

练习一:pc 2 台;Router-PT 可扩展路由 2台(Switch_2811 无V.35 线接口);Switch_2960 2台;DCE 串口线;直连线;交叉线

练习二:PC 2 台;Switch_3560 1 台;Router-PT 2台;直连线;交叉线;DCE 串口线

实验拓扑分别如图1、图2所示。

 

1 练习一实验拓扑图

 

2 练习二实验拓扑图

 

1)练习一的配置命令清单

PC1

IP: 192.168.1.2

Submask: 255.255.255.0

Gateway: 192.168.1.1

PC2

IP: 192.168.2.2

Submask: 255.255.255.0

Gateway: 192.168.2.1

R1

en

conf t

hostname R1

int fa 1/0

no shut

ip address 192.168.1.1 255.255.255.0

exit

int serial 2/0

no shut

ip address 192.168.3.1 255.255.255.0

clock rate 64000(必须配置时钟才可通信)

end

 

R2

en

conf t

hostname R2

int fa 1/0

no shut

ip address 192.168.2.1 255.255.255.0

exit

int serial 2/0

ip address 192.168.3.2 255.255.255.0

no shut

end

 

R1

en

conf t

ip route 192.168.2.0 255.255.255.0 192.168.3.2

end

show ip route

 

R2

en

conf t

ip route 192.168.1.0 255.255.255.0 192.168.3.1

end

show ip route

 

2)练习二的配置命令清单

PC1

IP: 192.168.1.2

Submask: 255.255.255.0

Gateway: 192.168.1.1

PC2

IP: 192.168.2.2

Submask: 255.255.255.0

Gateway: 192.168.2.1

S3560

en

conf t

hostname S3560

vlan 10

exit

vlan 20

exit

interface fa 0/10

switchport access vlan 10

exit

interface fa 0/20

switchport access valn 20

exit

end

show vlan

conf t

interface vlan 10

ip address 192.168.1.1 255.255.255.0

no shutdown

exit

interface vlan 20

ip address 192.168.3.1 255.255.255.0

no shutdown

end

show ip route

show running

conf t

ip routing

router rip

network 192.168.1.0

network 192.168.3.0

version 2

end

show ip route

 

 

 

R1

en

conf t

hostname R1

interface fa 0/0

no shutdown

ip address 192.168.3.2 255.255.255.0

interface serial 2/0

no shutdown

ip address 192.168.4.1 255.255.255.0

clock rate 64000

end

show ip route

conf t

router rip

network 192.168.3.0

network 192.168.4.0

version 2

exit

 

R2

en

conf t

hostname R2

interface fa 0/0

no shutdown

ip address 192.168.2.1 255.255.255.0

interface serial 2/0

no shutdown

ip address 192.168.4.2 255.255.255.0

end

show ip route

conf t

router rip

network 192.168.2.0

netword 192.168.4.0

version 2

end

 

 

顶 0踩 0收藏
分享到:
更多
文章评论
    发表评论

    个人资料

    • 昵称: 柯侧耳倾听者
    • 等级: 初级设计师
    • 积分: 2220
    • 代码: 64 个
    • 文章: 64 篇
    • 随想: 5 条
    • 访问: 31 次
    • 关注

    标签

    最新提问

      站长推荐