用户注册



邮箱:

密码:

用户登录


邮箱:

密码:
记住登录一个月忘记密码?

发表随想


还能输入:200字

柯侧耳倾听者    -  云代码空间

—— 翱翔在Java世界的海洋之上

双核心双出口网络设计

2018-01-06|138阅||

摘要:双核心双出口网络设计 【项目背景】 A公司企业网络的拓扑结构如下图所示。内部划分二个VLAN,即VLAN 1X、VLAN 2X。PC0、PC2属于VLAN1X,PC1、PC3属于VLAN 2X。VLAN 1X的IP地址范围:192.168.1X.0/24,VLAN 2

双核心双出口网络设计

【项目背景】

A公司企业网络的拓扑结构如下图所示。内部划分二个VLAN,即VLAN 1XVLAN 2XPC0PC2属于VLAN1XPC1PC3属于VLAN 2XVLAN 1XIP地址范围:192.168.1X.0/24VLAN 2XIP地址范围:192.168.2X.0/24。由于业务的需要,采用了双核心、双出口设计。

 

 

1  A公司企业网拓扑结构

【任务要求】

(注意:请使用Packet tracer 6.2以上版本的模拟器搭建上面网络拓扑,网络中共有192.168.1X.0192.168.2X.0201.1.1X.0202.2.2X.0203.1.1X.0204.2.2X.0205.1.1X.0七个网段,子网掩码均为255.255.255.0,完成以下配置,并验证。)

任务1:双核心、双出口负载均衡配置

 

要求将以两个三层交换机为核心,进行双出口冗余路由(HSRP)配置,即VLAN 1X默认从上面的链路通过PAT与外网连接,VLAN 2X默认从下面的链路通过PAT与外网连接。并要求配置接口追踪。请完成配置,并验证。

 

任务2:在公司内部网络进行链路聚合和链路冗余配置

要求在二台三层交换机之间实现链路聚合以加大核心交换机之间带宽。

要求在二层交换机与三层核心交换机之间进行链路冗余配置,并配置生成树协议,且VLAN 1X的生成树以上面的交换机为根;VLAN 2X的生成树以下面的交换机为根。

 

2  任务2的拓扑结构

【配置参考与提示】

(配置步骤及内容参考与提示中,各个命令中用到的IP地址请参见前面“注意”中的提示要求)

任务一:双核心、双出口负载均衡配置

1.将拓扑中代表Internet部分与A公司企业网连通

假设拓扑中代表Internet部分的三台路由器使用RIP协议,请将Internet网络与公司两台三层交换机之间连通。

 

1)在两个三层交换机设置三层接口,并给三层接口配置IP地址

假设两个三层交换机都是F0/3口连接外部路由器。现将三层交换机的F0/3口设置为三层接口,并配置IP地址。(假设地址分别为201.1.1X.1/24202.2.2X.1/24

Multilayer Switch0

en

conf t

int fa 0/3

no switchport

ip add 201.1.16.1 255.255.255.0

no shutdown

exit

Multilayer Switch1

en

conf t

int fa 0/3

no switchport

ip add 202.2.26.1 255.255.255.0

no shutdown

exit

 

(2)设置各路由器上各接口的IP地址,并在各路由器上启用RIP协议

Router0

en

conf t

int fa 0/0

ip add 201.1.16.2 255.255.255.0

no shutdown

exit

int fa 0/1

ip add 203.1.16.1 255.255.255.0

no shut

exit

    router rip

network 201.1.16.0

network 203.1.16.0

End

 Router1

en

conf t

int fa 0/0

ip add 202.2.26.2 255.255.255.0

no shutdown

exit

int fa 0/1

ip add 204.2.26.1 255.255.255.0

no shut

exit

router rip

network 202.2.26.0

network 204.2.26.0

end

Router2

en

conf t

int fa 0/0

ip add 203.1.16.2 255.255.255.0

no shutdown

exit

int fa 0/1

ip add 204.2.26.2 255.255.255.0

no shut

exit

int fa 0/3

ip add 205.1.16.1 255.255.255.0

no shut

router rip

network 203.1.16.0

network 204.2.26.0

network 205.1.16.0

end

(3)设置PC4IP地址(205.1.1X.2)与默认网关,验证从PC4到二个三层交换机的三层接口之间的连通性。

 

2.配置各PCIP地址

PC0192.168.1X.1/24PC1192.168.2X.1/24

 

 

PC2192.168.1X.2/24PC3192.168.2X.2/24

 

 

3.二层交换机的配置

1)在二层交换机上配置VLAN 1XVLAN 2X,并将相关的端口分别加入到相应的VLAN中。

witch0

en

conf  t

vlan 16

exit

vlan 26

exit

int fa 0/1

switchport access vlan 16

exit

int fa 0/2

switchport access vlan 26

exit


Switch1

en

conf  t

vlan 16

exit

vlan 26

exit

int fa 0/1

switchport access vlan 16

exit

int fa 0/2

switchport access vlan 26

exit

 

(2)将二层交换机通往三层交换机的端口配置为TRUNK

Switch0

int fa 0/3

switchport mode trunk

exit


Switch1

int fa 0/3

switchport mode trunk

exit

 

4.三层交换机上的配置

1)在二台三层交换机上都配置VLAN 1XVLAN 2X;设置SVI接口;

Multilayer Switch0

en

conf t

vlan 16

exit

vlan 26

exit

int vlan 16

ip add 192.168.16.5 255.255.255.0

no shut

exit

int vlan 26

ip add 192.168.26.5 255.255.255.0

no shut

exit


Multilayer Switch1

en

conf t

vlan 16

exit

vlan 26

exit

int vlan 16

ip add 192.168.16.6 255.255.255.0

no shut

exit

int vlan 26

ip add 192.168.26.6 255.255.255.0

no shut

exit

 

(2)启动三层交换。

3)配置默认路由,分别指向三层交换机连接的路由器的接口IP

4)在二台三层交换机上进行PAT配置

Multilayer Switch0

ip route 0.0.0.0 0.0.0.0 202.2.26.2

Multilayer Switch1

ip route 0.0.0.0 0.0.0.0 201.1.16.2

 

Multilayer Switch0

en

conf t

access-list 1 permit 192.168.0.0  0.0.255.255

ip nat pool natpool 201.1.16.1 201.1.16.1 netmask 255.255.255.0

ip nat inside source list 1 pool natpool overload

interface vlan 16

ip nat inside

exit

interface vlan 26

ip nat inside

exit

interface FastEthernet0/3

ip nat outside


Multilayer Switch0

interface vlan 16

ip address 192.168.16.5 255.255.255.0

ip nat inside

standby 1 ip 192.168.16.254

standby 1 priority 105

standby 1 preempt

exit

interface vlan 26

ip address 192.168.26.5 255.255.255.0

ip nat inside

standby 2 ip 192.168.26.254

standby 2 preempt

    interface vlan 16

ip address 192.168.16.5 255.255.255.0

standby 1 ip 192.168.16.254

standby 1 preempt

exit

interface vlan 26

ip address 192.168.26.5 255.255.255.0

standby 2 ip 192.168.26.254

standby 2 priority 105

standby 2 preempt


Multilayer Switch0

interface vlan 16

ip address 192.168.16.5 255.255.255.0

ip nat inside

standby 1 ip 192.168.16.254

standby 1 priority 105

standby 1 preempt

standby 1 track fastethernet 0/3


Multilayer Switch0

interface  port-channel 1

int range f 0/5-6

  channel-group  1  mode  on

 

Multilayer Switch1

interface  port-channel 1

int range f 0/5-6

    channel-group  1  mode  on


Multilayer Switch0

en

show spanning-tree

spanning-tree vlan 16 priority 16384


Multilayer Switch1

spanning-tree vlan 26 priority 4096

 

上面的三层交换机的NAT:

access-list 1 permit 192.168.0.0  0.0.255.255

ip nat pool natpool 201.1.1.1 201.1.1.1 netmask 255.255.255.0

ip nat inside source list 1 pool natpool overload

interface Vlan10

ip nat inside

interface Vlan20

ip nat inside

interface FastEthernet0/3

ip nat outside

完成此配置后,从PC0可以pingPC4了。

 

 

 

 

 

5VLANHSRP配置

上面的三层交换机:

interface Vlan10

ip address 192.168.1.252 255.255.255.0

ip nat inside

standby version 2

standby 1 ip 192.168.1.254

standby 1 priority 105

standby 1 preempt

!

interface Vlan20

ip address 192.168.2.252 255.255.255.0

ip nat inside

standby version 2

standby 2 ip 192.168.2.254

standby 2 preempt

下面的三层交换机:

interface Vlan10

ip address 192.168.1.253 255.255.255.0

standby version 2

standby 1 ip 192.168.1.254

standby 1 preempt

!

interface Vlan20

ip address 192.168.2.253 255.255.255.0

standby version 2

standby 2 ip 192.168.2.254

standby 2 priority 105

standby 2 preempt

 

Switch0

 

 

此时,如果我们将上图中与上面三层交换机相连的Router与交换机相连的接口关闭的话,可以发现,PC0ping不通PC4了。为什么会这样呢?怎么解决呢?答案就是配置接口追踪。

 

 

我们要上面的三层交换机HSRP的配置中增加一条接口追踪就可以了。

interface Vlan10

ip address 192.168.1.252 255.255.255.0

ip nat inside

standby version 2

standby 1 ip 192.168.1.254

standby 1 priority 105

standby 1 preempt

standby 1 track fastethernet 0/3

当我们加上此条后,当Router2与上面的三层交换机相连的接口关闭后,PC0PC4ICMP包会通过下面的三层交换机传向PC4

 

任务2:在公司内部网络进行链路聚合和链路冗余配置

任务二网络拓扑图如下:

 

1.在二个三层交换机之间配置链路聚合

Switch(config)# interface  端口类型 端口号

Switch(config-if)# channel-group  组号  mode  on

Switch0

 

Switch1

 

2.在交换机上配置生成树协议,并将二个三层交换机分别设置成VLAN 1XVLAN 2X的根(通过设置优先级来实现)。

Switch0

 

Switch1

 

 

 

 

顶 0踩 0收藏
分享到:
更多
文章评论
    发表评论

    个人资料

    • 昵称: 柯侧耳倾听者
    • 等级: 初级设计师
    • 积分: 2220
    • 代码: 64 个
    • 文章: 64 篇
    • 随想: 5 条
    • 访问: 35 次
    • 关注

    标签

    最新提问

      站长推荐